import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:\\d+%(?: |for)+([A-Z](?:[\\w\\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*";
final String string = "95% for Pikachu, 92% for Mr. Mime\n"
+ "70% for Paras & 100% Arcanine\n"
+ "99% Diglett, 40% Dugtrio\n"
+ "10% Squirtle, 100% for Alakazam\n"
+ "30% Metopod & 99% Nidoran♂";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}