use strict;
my $str = '95% for Pikachu, 92% for Mr. Mime
70% for Paras & 100% Arcanine
99% Diglett, 40% Dugtrio
10% Squirtle, 100% for Alakazam
30% Metopod & 99% Nidoran♂';
my $regex = qr/(?:(?:\d+%(?: |for)+([A-Z](?:[\w\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}