import re
regex = re.compile(r"(?:(?:\d+%(?: |for)+([A-Z](?:[\w\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*", flags=re.MULTILINE)
test_str = ("95% for Pikachu, 92% for Mr. Mime\n"
"70% for Paras & 100% Arcanine\n"
"99% Diglett, 40% Dugtrio\n"
"10% Squirtle, 100% for Alakazam\n"
"30% Metopod & 99% Nidoran♂")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")