const regex = new RegExp('(?:(?:\\d+%(?: |for)+([A-Z](?:[\\w\\.♀♂\\']|(?: (?=[A-Z])))+))+)[, &]*', 'gm')
const str = `95% for Pikachu, 92% for Mr. Mime
70% for Paras & 100% Arcanine
99% Diglett, 40% Dugtrio
10% Squirtle, 100% for Alakazam
30% Metopod & 99% Nidoran♂`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}