#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)tooltext=(.*?\\&)*.*?&"
Local $sString = "'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89&color=ff0000|00ffff'" & @CRLF & _
"'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89'" & @CRLF & _
"'&label=20:01:27&tooltext=abc&|\|cba&value=6|59|58|89'" & @CRLF & _
"'&label=20:01:27&tooltext=abc\&\as&\&dsa\&|\|cba&value=6|59|58|89'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")