const regex = /tooltext=(.*?\\&)*.*?&/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('tooltext=(.*?\\\\&)*.*?&', 'igm')
const str = `'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89&color=ff0000|00ffff'
'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc&|\\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc\\&\\as&\\&dsa\\&|\\|cba&value=6|59|58|89'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}