package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)tooltext=(.*?\\&)*.*?&`)
var str = `'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89&color=ff0000|00ffff'
'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc&|\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc\&\as&\&dsa\&|\|cba&value=6|59|58|89'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}