use strict;
my $str = '\'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89&color=ff0000|00ffff\'
\'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89\'
\'&label=20:01:27&tooltext=abc&|\\|cba&value=6|59|58|89\'
\'&label=20:01:27&tooltext=abc\\&\\as&\\&dsa\\&|\\|cba&value=6|59|58|89\'';
my $regex = qr/tooltext=(.*?\\&)*.*?&/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}