import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tooltext=(.*?\\\\&)*.*?&";
final String string = "'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89&color=ff0000|00ffff'\n"
+ "'&label=20:01:27&tooltext=abc\\&|\\|cba&value=6|59|58|89'\n"
+ "'&label=20:01:27&tooltext=abc&|\\|cba&value=6|59|58|89'\n"
+ "'&label=20:01:27&tooltext=abc\\&\\as&\\&dsa\\&|\\|cba&value=6|59|58|89'";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}