using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tooltext=(.*?\\&)*.*?&";
string input = @"'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89&color=ff0000|00ffff'
'&label=20:01:27&tooltext=abc\&|\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc&|\|cba&value=6|59|58|89'
'&label=20:01:27&tooltext=abc\&\as&\&dsa\&|\|cba&value=6|59|58|89'";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}