#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$"
Local $sString = "2001:db8:3333:4444:5555:6666:7777:8888" & @CRLF & _
"2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF" & @CRLF & _
"::" & @CRLF & _
"2001:db8::" & @CRLF & _
"::1234:5678" & @CRLF & _
"2001:db8::1234:5678" & @CRLF & _
"2001:0db8:0001:0000:0000:0ab9:C0A8:0102" & @CRLF & _
"2001:db8:1::ab9:C0A8:102" & @CRLF & _
"::1" & @CRLF & _
"" & @CRLF & _
"asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")