re = /^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$/im
str = '2001:db8:3333:4444:5555:6666:7777:8888
2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF
::
2001:db8::
::1234:5678
2001:db8::1234:5678
2001:0db8:0001:0000:0000:0ab9:C0A8:0102
2001:db8:1::ab9:C0A8:102
::1
asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end