import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$";
final String string = "2001:db8:3333:4444:5555:6666:7777:8888\n"
+ "2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF\n"
+ "::\n"
+ "2001:db8::\n"
+ "::1234:5678\n"
+ "2001:db8::1234:5678\n"
+ "2001:0db8:0001:0000:0000:0ab9:C0A8:0102\n"
+ "2001:db8:1::ab9:C0A8:102\n"
+ "::1\n\n"
+ "asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}