import Foundation
let pattern = #"^(?:(?:[a-f0-9]*)?:){1,7}[a-f0-9]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
2001:db8:3333:4444:5555:6666:7777:8888
2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF
::
2001:db8::
::1234:5678
2001:db8::1234:5678
2001:0db8:0001:0000:0000:0ab9:C0A8:0102
2001:db8:1::ab9:C0A8:102
::1
asdlkjkjd:asldjlaskdjlkja:lasdkjlkajsd:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)