#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)"
Local $sString = "Peter Svidler" & @CRLF & _
"PEter Svidler" & @CRLF & _
"V Anand" & @CRLF & _
"Botvinnik M M" & @CRLF & _
"Vivekanand P V" & @CRLF & _
"27261<72<627" & @CRLF & _
"PeTER Svidel" & @CRLF & _
"Peter Parker" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")