using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)";
string input = @"Peter Svidler
PEter Svidler
V Anand
Botvinnik M M
Vivekanand P V
27261<72<627
PeTER Svidel
Peter Parker
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}