import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\\b)";
final String string = "Peter Svidler\n"
+ "PEter Svidler\n"
+ "V Anand\n"
+ "Botvinnik M M\n"
+ "Vivekanand P V\n"
+ "27261<72<627\n"
+ "PeTER Svidel\n"
+ "Peter Parker\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}