// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)").unwrap();
let string = "Peter Svidler
PEter Svidler
V Anand
Botvinnik M M
Vivekanand P V
27261<72<627
PeTER Svidel
Peter Parker
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}