import re
regex = re.compile(r"(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)", flags=re.MULTILINE)
test_str = ("Peter Svidler\n"
"PEter Svidler\n"
"V Anand\n"
"Botvinnik M M\n"
"Vivekanand P V\n"
"27261<72<627\n"
"PeTER Svidel\n"
"Peter Parker\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")