$re = '/(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)/m';
$str = 'Peter Svidler
PEter Svidler
V Anand
Botvinnik M M
Vivekanand P V
27261<72<627
PeTER Svidel
Peter Parker
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);