const regex = /(\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b[A-Z][a-z]* [A-Z][a-z]*(?: [A-Z])?\\b)', 'gm')
const str = `Peter Svidler
PEter Svidler
V Anand
Botvinnik M M
Vivekanand P V
27261<72<627
PeTER Svidel
Peter Parker
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}