#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(@ag-grid-.*:).*,"
Local $sString = ""@ag-grid-community/all-modules": "22.1.3"," & @CRLF & _
""@ag-grid-community/angular": "22.1.4"," & @CRLF & _
""another-package": "2.1.4"," & @CRLF & _
"" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")