import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(@ag-grid-.*:).*,";
final String string = "\"@ag-grid-community/all-modules\": \"22.1.3\",\n"
+ "\"@ag-grid-community/angular\": \"22.1.4\",\n"
+ "\"another-package\": \"2.1.4\",\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}