$re = '/"(@ag-grid-.*:).*,/m';
$str = '"@ag-grid-community/all-modules": "22.1.3",
"@ag-grid-community/angular": "22.1.4",
"another-package": "2.1.4",
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);