package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(@ag-grid-.*:).*,`)
var str = `"@ag-grid-community/all-modules": "22.1.3",
"@ag-grid-community/angular": "22.1.4",
"another-package": "2.1.4",
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}