using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(@ag-grid-.*:).*,";
string input = @"""@ag-grid-community/all-modules"": ""22.1.3"",
""@ag-grid-community/angular"": ""22.1.4"",
""another-package"": ""2.1.4"",
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}