re = /"(@ag-grid-.*:).*,/m
str = '"@ag-grid-community/all-modules": "22.1.3",
"@ag-grid-community/angular": "22.1.4",
"another-package": "2.1.4",
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end