// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(@ag-grid-.*:).*,"#).unwrap();
let string = "\"@ag-grid-community/all-modules\": \"22.1.3\",
\"@ag-grid-community/angular\": \"22.1.4\",
\"another-package\": \"2.1.4\",
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}