import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Cat\\b(?:(?!^Cat\\b).)*\\bdog\\b(?=\\R+Cat\\b|\\z)";
final String string = "Cat poem: \n"
+ "My feline is very dog\n"
+ "I like furry felines\n"
+ "This is why I do not have a dog\n\n"
+ "Cat poem:\n"
+ "Littly furry paws\n"
+ "this is what i like\n"
+ "I don't care if it's a feline or a canine\n\n"
+ "Cat poem:\n"
+ "The little felines dog\n"
+ "playing in the field dog\n"
+ "sitting on the side watching is a dog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}