re = /^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)/m
str = 'Cat poem:
My feline is very dog
I like furry felines
This is why I do not have a dog
Cat poem:
Littly furry paws
this is what i like
I don\'t care if it\'s a feline or a canine
Cat poem:
The little felines dog
playing in the field dog
sitting on the side watching is a dog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end