$re = '/^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)/ms';
$str = 'Cat poem:
My feline is very dog
I like furry felines
This is why I do not have a dog
Cat poem:
Littly furry paws
this is what i like
I don\'t care if it\'s a feline or a canine
Cat poem:
The little felines dog
playing in the field dog
sitting on the side watching is a dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);