const regex = /^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)/mgs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Cat\\b(?:(?!^Cat\\b).)*\\bdog\\b(?=\\R+Cat\\b|\\z)', 'mgs')
const str = `Cat poem:
My feline is very dog
I like furry felines
This is why I do not have a dog
Cat poem:
Littly furry paws
this is what i like
I don't care if it's a feline or a canine
Cat poem:
The little felines dog
playing in the field dog
sitting on the side watching is a dog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}