use strict;
my $str = 'Cat poem:
My feline is very dog
I like furry felines
This is why I do not have a dog
Cat poem:
Littly furry paws
this is what i like
I don\'t care if it\'s a feline or a canine
Cat poem:
The little felines dog
playing in the field dog
sitting on the side watching is a dog';
my $regex = qr/^Cat\b(?:(?!^Cat\b).)*\bdog\b(?=\R+Cat\b|\z)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}