#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*[<(]|[>)].*"
Local $sString = "Some Name <same.name@example.com>" & @CRLF & _
"same.name2@example.com" & @CRLF & _
"Some Name3 (same.name3@example.com)" & @CRLF & _
"Some Name4 (same.name4@example.com)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")