using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*[<(]|[>)].*";
string input = @"Some Name <same.name@example.com>
same.name2@example.com
Some Name3 (same.name3@example.com)
Some Name4 (same.name4@example.com)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}