import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*[<(]|[>)].*";
final String string = "Some Name <same.name@example.com>\n"
+ "same.name2@example.com\n"
+ "Some Name3 (same.name3@example.com)\n"
+ "Some Name4 (same.name4@example.com)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}