re = /^.*[<(]|[>)].*/m
str = 'Some Name <same.name@example.com>
same.name2@example.com
Some Name3 (same.name3@example.com)
Some Name4 (same.name4@example.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end