package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[<(]|[>)].*`)
var str = `Some Name <same.name@example.com>
same.name2@example.com
Some Name3 (same.name3@example.com)
Some Name4 (same.name4@example.com)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}