import re
regex = re.compile(r"^.*[<(]|[>)].*", flags=re.MULTILINE)
test_str = ("Some Name <same.name@example.com>\n"
"same.name2@example.com\n"
"Some Name3 (same.name3@example.com)\n"
"Some Name4 (same.name4@example.com)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")