$re = '/^.*[<(]|[>)].*/m';
$str = 'Some Name <same.name@example.com>
same.name2@example.com
Some Name3 (same.name3@example.com)
Some Name4 (same.name4@example.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);