# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B@\p{L}+/<span>$&<\/span>/gmu;t' <<< "@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
"