use strict;
my $str = '@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
';
my $regex = qr/\B@\p{L}+/mup;
my $subst = '<span>$&</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";