const regex = /\B@\p{L}+/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B@\\p{L}+', 'gmu')
const str = `@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
`;
const subst = `<span>$&</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);