re = /\B@\p{L}+/m
str = '@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
'
subst = '<span>$&</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result