// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)\B@\p{L}+").unwrap();
let string = "@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
";
let substitution = "<span>$&</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}