import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"\B@\p{L}+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$&</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)