using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B@\p{L}+";
string substitution = @"<span>$&</span>";
string input = @"@John lorem ipsum @ dolor
sit @Mark amet @@adipiscin@ elit @Šapa!
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}