#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*"
Local $sString = "HTTP/122.0 404 Not Found" & @CRLF & _
"Cache-Control: no-cache" & @CRLF & _
"Content-Type: application/json" & @CRLF & _
"{asad}" & @CRLF & _
"" & @CRLF & _
"{cool}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")