using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*";
string input = @"HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}