re = /HTTP\/\d*.\d*\s.*\sCache-Control:\s.*\s[^\{.\}]*/
str = 'HTTP/122.0 404 Not Found
Cache-Control: no-cache
Content-Type: application/json
{asad}
{cool}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end